Commerce for Umbraco Installsion Problems

Aug 7, 2009 at 4:41 PM
Edited Aug 7, 2009 at 4:42 PM

Greetings,

I've recently installed Umbraco 4.0.2.1 on my web server with MSSQL 2008 as the database provider. I've successfully (I would think) installed Commerce for Umbraco, but I ran into problems instantly.

The Commerce section of Umbraco outputs an error page shown below where the content page should be.

Invalid object name 'dbo.CSK_Store_Order'.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Data.SqlClient.SqlException: Invalid object name 'dbo.CSK_Store_Order'.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.


Stack Trace:

[SqlException (0x80131904): Invalid object name 'dbo.CSK_Store_Order'.]
   System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection) +1950890
   System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection) +4846875
   System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj) +194
   System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj) +2392
   System.Data.SqlClient.SqlDataReader.ConsumeMetaData() +33
   System.Data.SqlClient.SqlDataReader.get_MetaData() +83
   System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString) +297
   System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async) +954
   System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, DbAsyncResult result) +162
   System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method) +32
   System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior behavior, String method) +141
   System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior behavior) +70
   SubSonic.SqlDataProvider.GetReader(QueryCommand qry) +208
   SubSonic.DataService.GetReader(QueryCommand cmd) +22
   SubSonic.AbstractList`2.Load() +550
   CommerceForUmbraco.adminSection.commerce.dashboardOverview.BindData() +1255
   CommerceForUmbraco.adminSection.commerce.dashboardOverview.Page_Load(Object sender, EventArgs e) +398
   System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +14
   System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +35
   System.Web.UI.Control.OnLoad(EventArgs e) +99
   System.Web.UI.Control.LoadRecursive() +50
   System.Web.UI.Control.LoadRecursive() +141
   System.Web.UI.Control.LoadRecursive() +141
   System.Web.UI.Control.LoadRecursive() +141
   System.Web.UI.Control.LoadRecursive() +141
   System.Web.UI.Control.LoadRecursive() +141
   System.Web.UI.Control.LoadRecursive() +141
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +627


Version Information: Microsoft .NET Framework Version:2.0.50727.3082; ASP.NET Version:2.0.50727.3082

 

How may I fix this?

 

Coordinator
Aug 7, 2009 at 4:50 PM

I believe that your Commerce SQL Schema qualifier is not DBO.  This is a legacy limitation from the project's dashCommerce roots in that the SQL Schema must be qualified with DBO.

I'm not sure if you can easily change the schema qualifier, but you can always reinstall the SQL portion using the scripts in:

    .../sql/CreateFullCommerce.sql

-Paul

 

Aug 7, 2009 at 11:19 PM

I couldn't find the file you mentioned, but I installed Commerce for Umbraco 1.1 Beta after unstalling the previous one, but when I attempt to proceed to Step 4 of 6 in the Commerce for Umbraco installer, I obtain a invalid MAC error where my machine key is invalid for some reason.

What file do I insert a generated machine key, or do you have another solution?

Coordinator
Aug 10, 2009 at 3:46 PM

There's nothing in the installer that references or requires a MAC address so I doubt that is related.  You may check the <authentication... section in web.config as a machine key can be set here to encrypt the auth ticket.

Can you clarify 'step 4 of 6' as the installer does not have steps per se?

Thanks,

-Paul

Aug 10, 2009 at 5:08 PM

The previous error was the first attempt to install the package successfully of which it didn't. I've tried thereafter using the 1.1 Umbraco package, and tried to follow the instructions well. I've attempted to 'update the 'web.config' with 'sample.config', but no success on what I should be updating. I've tried to use Beyond Compare, and manually. The Commerce Installer gives me issues of the config file, and then I have to resort back to the original.

Also, somehow I corrupting my Adminstrator nodes when I've done some of the installer steps. I don't know how.

Regards,

Kevin Keeney

Coordinator
Aug 10, 2009 at 5:15 PM

Kevin -

The v1.1 package is *ONLY* compatible with the Beta versions of Umbraco 4 - which, I assume, you're not using.  The issue with the Umbraco UI has to do with the move from TinyMCE 2 to 3.  I'd stick with the Commerce v1 Bets package.  I'd try this on a clean v4.0.2.1 install as it really does work - many 100's of installations have been done.

-Paul

Aug 10, 2009 at 8:38 PM

I think I found a solution of how to succesfully connect to the database at the Commerce section, but I don't know how to change the default schema, and have it set to '.dbo'.

How do I? I've resorted back to a clean installsion, and tried to look for a setting in the config files, but no luck yet.

Coordinator
Aug 10, 2009 at 9:00 PM

The schema qualifier is set in the database, not in a .config file.  Have a look at your database in Management Studio and I think you'll see the issue. 

Your tables need to have the [dbo] qualifier in front of the table name - I'm guessing yours has [umbracouser] or something similar.

-Paul